Depuis la deuxième quinzaine de mai 2011, 1&1 a modifié ses offres d'hébergement mutualisé et ajouté de nouvelles fonctionnalités à certains anciens packs d'hébergement mutualisé (voire à tous, je n'ai pas tout vérifié).

Une première fonctionnalité notable est la possibilité de choisir la version de PHP fonctionnant par défaut pour le serveur, la version 4 n'étant plus proposée en Dual Hosting, la version "dev" étant PHP 6. L'intérêt est de s'affranchir de la nécessité de la ligne dans le .htaccess pour passer PHP en version 5, pour les sites Joomla! notamment. Par contre, Joomla! est incompatible avec PHP 6.

Pour les Dual Hosting, des "réglages locaux" permettent de forcer une autre version de PHP pour un site (plus précisément un répertoire de site) donné : un gadget à mon avis, les réglages par défaut étant parfaitement compatibles avec Joomla! et ne nécessitant a priori pas de modification.

Ces offres Dual Hosting permettent aussi l'accès à "Click & Build" : je vous déconseille fortement l'utilisation de ce système d'installation de scripts, compte tenu des restrictions majeures imposées par 1&1 dans la gestion du site qui est généré. Je cite l'avertissement présent actuellement sur la page de choix du script à installer :

Remarque importante :

Pour des raisons de sécurité, les modifications et configurations suivantes des applications Click & Build sont impossibles :

  • Installation de nouveaux modèles, Plugins, modules, composants ou packs linguistiques.
  • Insertion de vos propres codes sources (par ex. HTML, CSS, JavaScript ou PHP) dans des modèles préinstallés ou autres champs dans les applications Click & Build.
Merci de votre compréhension.

Ces restrictions majeures m'ont instantanément refroidi... et absolument pas donné l'envie de tester ce type d'installation ! J'ignore donc si la base de données utilisée par ces scripts est accessible depuis la gestion du pack ou non, ce qui serait une restriction supplémentaire...

Mise à jour 14/12/2012 : depuis quelques mois, la version "dev" de PHP est la 5.4

Pour ceux qui ne peuvent régler la version depuis l'administration du compte, il leur faut utiliser l'instruction suivante en début de .htaccess :

AddHandler x-mapp-php6 .php3 .php4 .php .phtml